Help

Minimum System Requirements

For best user experience and your information security, we recommend that you use the most up-to-date version of your favorite internet browser. However, we understand that sometimes this is not possible but we have the following are the minimum system requirements to use CPALMS:

Desktops and laptops

Tablets and smart phones

Most but not all of CPALMS is accessible by Tablets and Smart Phones. The components that are not accessible via a tablet/phone are the: iCPALMS CMAP, Visualizer, and Progression Mapping Tools. These tools require the Microsoft Silverlight Plug-in that is not supported by most of these devices. Please make sure your operating system is up to date for the rest of CPALMS to work properly.

Special Note: If you are using a tablet that runs a full operating system such as Microsoft Windows 8+, you are able to use all the CPALMS features given you install the appropriate plug-ins that are specified under the Desktops and Laptops section.